R4itt 3DS Cards can Work on 3DS V6.2.0-12U/E/J!

The upgrade firmware of R4itt 3DS card for 3DS 6.2.0 has been officially released! With its latest upgrade patch, the R4itt 3DS cardcan be updated to be compatible with 3DS V6.2.0-12U/E/J.

r4itt-3ds-01

Firmware Upgrade File for R4itt 3DS Card: Download

Kernel for R4itt 3DS Card: Download

Note: You should update your R4itt 3DS cards on the 3DS system version lower than 6.2.0 or a DSi/DS Lite/DS console.

Here is a good news, the flashcarts online store, Dwtechz.com provides pre-flashed R4itt 3DS cards, you do not need any update or patch.

The rts function has been added to the R4itt 3DS cards, so you can also enjoy RTS function with R4itt 3DS cards when you play games.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s